EveryPay - Issues with Open Banking payments processing – Incident details

All systems operational

Issues with Open Banking payments processing

Resolved
Degraded performance
Started 6 days agoLasted about 20 hours

Affected

Bank APIs

Degraded performance from 7:10 PM to 3:30 PM

LHV

Degraded performance from 7:10 PM to 3:30 PM

Swedbank Estonia

Degraded performance from 7:10 PM to 3:30 PM

Swedbank Latvia

Degraded performance from 7:10 PM to 3:30 PM

Swedbank Lithuania

Degraded performance from 7:10 PM to 3:30 PM

SEB Estonia

Degraded performance from 7:10 PM to 3:30 PM

Updates
  • Resolved
    Resolved

    We would like to inform you that the issues with Open Banking processing have been resolved on 24.11. 2025 at 17:30.

    We apologize for any inconvenience this may have caused and appreciate your patience and understanding.

  • Investigating
    Investigating

    Please note that since 23.11. 2025 at 21:10, we have detected a partial disturbance affecting Open Banking processing. Our team is currently investigating the issue.

    We apologize for any inconvenience this may have caused and appreciate your understanding while we work to resolve it as quickly as possible.