EveryPay - Issues with Luminor bank payments – Incident details

All systems operational

Issues with Luminor bank payments

Resolved
Degraded performance
Started 10 days agoLasted about 1 hour

Affected

Bank APIs

Degraded performance from 11:40 AM to 12:45 PM

Luminor Latvia

Degraded performance from 11:40 AM to 12:45 PM

Updates
  • Resolved
    Resolved

    Please be informed that the issues with Luminor Latvia bank payments are resolved. Luminor apologizes for the inconvenience.

  • Investigating
    Investigating

    Please be informed that currently there are issues with Luminor Latvia bank payments.
    Luminor is currently working on the fix.