All systems operational

Luminor planned maintenance

Completed
Scheduled for June 06, 2024 at 22:00 (+00:00) – June 07, 2024 at 01:00 (+00:00)

Affects

Bank APIs
Luminor Estonia
Luminor Latvia
Luminor Lithuania
Updates
  • Completed
    June 07, 2024 at 01:00 (+00:00)
    Completed
    June 07, 2024 at 01:00 (+00:00)
    Maintenance has completed successfully
  • In progress
    June 06, 2024 at 22:00 (+00:00)
    In progress
    June 06, 2024 at 22:00 (+00:00)
    Maintenance is now in progress
  • Planned
    June 06, 2024 at 22:00 (+00:00)
    Planned
    June 06, 2024 at 22:00 (+00:00)

    Please be informed that Luminor will have a planned maintenance downtime.

    Luminor apologizes for the inconvenience.