All systems operational

Issues with Swedbank bank payments

Resolved
Degraded performance
Started 20 days ago Lasted about 1 hour

Affected

Bank APIs
Swedbank Estonia
Swedbank Latvia
Swedbank Lithuania
Updates
  • Resolved
    Resolved

    Please be informed that the issues with Swedbank bank payments are resolved. Swedbank apologizes for the inconvenience.

  • Investigating
    Investigating

    Please be informed that currently there are issues with Swedbank bank payments.
    Swedbank is currently working on the fix.