All systems operational

SEB Baltic service downtime for maintenance

Completed
Scheduled for May 18, 2024 at 01:00 (+00:00) – 05:00 (+00:00)

Affects

Bank APIs
SEB Estonia
SEB Latvia
SEB Lithuania
Updates
  • Completed
    May 18, 2024 at 05:00 (+00:00)
    Completed
    May 18, 2024 at 05:00 (+00:00)
    Maintenance has completed successfully
  • In progress
    May 18, 2024 at 01:00 (+00:00)
    In progress
    May 18, 2024 at 01:00 (+00:00)
    Maintenance is now in progress
  • Planned
    May 18, 2024 at 01:00 (+00:00)
    Planned
    May 18, 2024 at 01:00 (+00:00)

    Please be informed that SEB Baltic is going to have a planned maintenance. During the maintenance, SEB (EE, LV, LT) bank payments will not work.