All systems operational

Luminor planned maintenance

Completed
Scheduled for May 17, 2024 at 01:00 (+00:00) – 05:00 (+00:00)

Affects

Bank APIs
Luminor Latvia
Updates
  • Completed
    May 17, 2024 at 05:00 (+00:00)
    Completed
    May 17, 2024 at 05:00 (+00:00)
    Maintenance has completed successfully
  • In progress
    May 17, 2024 at 01:00 (+00:00)
    In progress
    May 17, 2024 at 01:00 (+00:00)
    Maintenance is now in progress
  • Planned
    May 17, 2024 at 01:00 (+00:00)
    Planned
    May 17, 2024 at 01:00 (+00:00)

    Please be informed that Luminor Latvia will have a planned maintenance downtime.

    Luminor apologizes for the inconvenience.