All systems operational

Luminor planned maintenance

Completed
Scheduled for April 13, 2024 at 20:45 (+00:00) – April 14, 2024 at 03:30 (+00:00)

Affects

Bank APIs
Luminor Estonia
Luminor Latvia
Luminor Lithuania
Updates
  • Completed
    April 14, 2024 at 03:30 (+00:00)
    Completed
    April 14, 2024 at 03:30 (+00:00)
    Maintenance has completed successfully
  • In progress
    April 13, 2024 at 20:45 (+00:00)
    In progress
    April 13, 2024 at 20:45 (+00:00)
    Maintenance is now in progress
  • Planned
    April 13, 2024 at 20:45 (+00:00)
    Planned
    April 13, 2024 at 20:45 (+00:00)

    Please be informed that Luminor will have a planned maintenance downtime.

    Luminor apologizes for the inconvenience.