All systems operational

Issues with LHV bank payments

Resolved
Partial outage
Started 2 months ago Lasted about 2 hours

Affected

Bank APIs
LHV
Updates
  • Resolved
    Resolved

    Please be informed that the issues with LHV bank payments are resolved.
    LHV apologizes for the inconvenience.

  • Investigating
    Investigating

    Please be informed that currently there are issues with LHV bank payments.
    LHV is currently working on the fix.