EveryPay - Issues with 3DS services – Incident details

Experiencing partial outage

Issues with 3DS services

Resolved
Major outage
Started over 1 year agoLasted 6 minutes

Affected

EveryPay

Major outage from 2:58 PM to 3:04 PM

Card Processing

Major outage from 2:58 PM to 3:04 PM

Updates
  • Resolved
    Resolved

    Please be informed that the issues with the 3DS services are resolved.
    Our 3D Secure processor apologizes for the inconvenience.

  • Investigating
    Investigating

    Please be informed that currently there are issues with 3DS services.
    Our 3D Secure processor is currently working on the fix.