All systems operational

Planned maintenance

Completed
Scheduled for March 27, 2024 at 07:00 (+00:00) – 07:15 (+00:00)

Affects

EveryPay
Card Processing
Payment Initiation Service
Merchant Portal
Updates
  • Completed
    March 27, 2024 at 07:15 (+00:00)
    Completed
    March 27, 2024 at 07:15 (+00:00)
    Maintenance has completed successfully
  • In progress
    March 27, 2024 at 07:00 (+00:00)
    In progress
    March 27, 2024 at 07:00 (+00:00)
    Maintenance is now in progress
  • Planned
    March 27, 2024 at 07:00 (+00:00)
    Planned
    March 27, 2024 at 07:00 (+00:00)

    We would like to inform you about the planned system upgrade to improve our platform. During the upgrade, short (1-2 minutes) interruption is expected. We apologize for any inconvenience this may cause.