All systems operational

Luminor planned maintenance

Completed
Scheduled for March 24, 2024 at 22:00 (+00:00) – March 25, 2024 at 02:00 (+00:00)

Affects

Bank APIs
Luminor Estonia
Luminor Latvia
Luminor Lithuania
Updates
  • Completed
    March 25, 2024 at 02:00 (+00:00)
    Completed
    March 25, 2024 at 02:00 (+00:00)
    Maintenance has completed successfully
  • In progress
    March 24, 2024 at 22:00 (+00:00)
    In progress
    March 24, 2024 at 22:00 (+00:00)
    Maintenance is now in progress
  • Planned
    March 24, 2024 at 22:00 (+00:00)
    Planned
    March 24, 2024 at 22:00 (+00:00)

    Please be informed that Luminor will have a planned maintenance downtime.
    Luminor apologizes for the inconvenience.