All systems operational

Luminor planned maintenance

Completed
Scheduled for January 25, 2024 at 23:30 (+00:00) – January 26, 2024 at 00:30 (+00:00)

Affects

Bank APIs
Luminor Estonia
Luminor Latvia
Luminor Lithuania
Updates
  • Completed
    January 26, 2024 at 00:30 (+00:00)
    Completed
    January 26, 2024 at 00:30 (+00:00)

    Maintenance has completed successfully

  • In progress
    January 25, 2024 at 23:30 (+00:00)
    In progress
    January 25, 2024 at 23:30 (+00:00)

    Maintenance is now in progress

  • Planned
    January 25, 2024 at 23:30 (+00:00)
    Planned
    January 25, 2024 at 23:30 (+00:00)

    Please be informed that Luminor will have a planned maintenance downtime.
    Luminor apologizes for the inconvenience.