EveryPay - Issues with payment processing – Incident details

All systems operational

Issues with payment processing

Resolved
Degraded performance
Started 3 days agoLasted 37 minutes

Affected

EveryPay

Degraded performance from 9:48 AM to 10:25 AM

Card Processing

Degraded performance from 9:48 AM to 10:25 AM

Payment Initiation Service

Degraded performance from 9:48 AM to 10:25 AM

Updates
  • Resolved
    Resolved

    Please be informed that the issues with payment processing are resolved. We apologize for any inconvenience this may have caused.

  • Investigating
    Investigating

    Please be informed that currently, there might be technical issues with payment processing. We are investigating the matter.