EveryPay - Issues with Citadele bank payments – Incident details

All systems operational

Issues with Citadele bank payments

Resolved
Degraded performance
Started 25 days agoLasted about 6 hours

Affected

Bank APIs

Degraded performance from 11:00 AM to 4:30 PM

Citadele Estonia

Degraded performance from 11:00 AM to 4:30 PM

Citadele Latvia

Degraded performance from 11:00 AM to 4:30 PM

Citadele Lithuania

Degraded performance from 11:00 AM to 4:30 PM

Updates
  • Resolved
    Resolved

    Please be informed that the issues with Citadele bank payments are resolved. Citadele apologizes for the inconvenience.

  • Investigating
    Investigating

    Please be informed that currently there are issues with Citadele bank payments.
    Citadele is currently working on the fix.