EveryPay - Issues with Luminor bank payments – Incident details

All systems operational

Issues with Luminor bank payments

Resolved
Degraded performance
Started 4 months agoLasted about 3 hours

Affected

Bank APIs

Degraded performance from 6:05 AM to 8:50 AM

Luminor Estonia

Degraded performance from 6:05 AM to 8:50 AM

Luminor Latvia

Degraded performance from 6:05 AM to 8:50 AM

Luminor Lithuania

Degraded performance from 6:05 AM to 8:50 AM

Updates
  • Resolved
    Resolved

    Please be informed that the issues with Luminor bank payments are resolved. Luminor apologizes for the inconvenience.

  • Investigating
    Investigating

    Please be informed that currently there are issues with Luminor bank payments.
    Luminor is currently working on the fix.