EveryPay - Issues with Citadele bank payments – Incident details

All systems operational

Issues with Citadele bank payments

Resolved
Major outage
Started about 2 years agoLasted about 3 hours

Affected

Bank APIs

Major outage from 12:07 PM to 3:00 PM

Citadele Estonia

Major outage from 12:07 PM to 3:00 PM

Citadele Latvia

Major outage from 12:07 PM to 3:00 PM

Citadele Lithuania

Major outage from 12:07 PM to 3:00 PM

Updates
  • Resolved
    Resolved

    Please be informed that the issues with Citadele bank payments are resolved.
    Citadele apologizes for the inconvenience.

  • Investigating
    Investigating

    Please be informed that currently there are issues with Citadele bank payments.
    Citadele is currently working on the fix.